Having issues running the latest LRM client 4.3.1?

Following the release of LRM 4.3.1 today a handful of the 200+ users that have already downloaded and installed it have reported issues when attempting to launch the new client.

If you experience the same issues, whilst we work to identify why this is happening for some users/on their computers we recommend that you uninstall the latest version and re-install LRM 4.0.0 (the previous version)

You can download the older version using this link.

Please also reply to this thread if you experienced the same problem (so we can keep tabs on how many people this is affecting).

We’ll be working to identify why this is affecting some users.

Hello, I’m having issues with the new version of LRM. After startup, a few seconds it seem to start, but then the application crash, and it disappears from task manager. :slightly_frowning_face::slightly_frowning_face:

Hi @lukaschylek,

Sorry to hear you’re having issues with the new client software, there has been a few other people have this issue too (but for the majority this has worked fine).

I wonder if this problem could be caused by the recent LetsEncrypt certificate updates and I would therefore recommend you check you have all operating system updates installed from Microsoft.

Could you try updating Windows first and if that DOES NOT fix the problem, could you let us know what version of Windows you are using and any error logs in the Microsoft Event Viewer.

You should be able to re-install the older LRM v4.0.0 if you prefer as this has worked for some other users (whilst we investigate what is causing this issue for some users)

Kind regards,
Bobby

Hello,

I also experience issues trying to start the new client, it never starts (crashes after a sec or so). I am running windows 11 i never tried the new version in windows 10. Hope the below info helps in troubleshooting.

The following two errors are found in the event viewer:
Application: LRM.exe
Framework Version: v4.0.30319
Description: The process was terminated due to an unhandled exception.
Exception Info: System.FormatException
at System.Number.StringToNumber(System.String, System.Globalization.NumberStyles, NumberBuffer ByRef, System.Globalization.NumberFormatInfo, Boolean)
at System.Number.ParseDecimal(System.String, System.Globalization.NumberStyles, System.Globalization.NumberFormatInfo)
at System.Convert.ToDecimal(System.String)
at LRM.Blackbox.RadioFreqency…ctor(System.String)
at LRM.Blackbox.FDRData…ctor()
at LRM.Blackbox.DataRecorder…ctor()
at LRM.MainForm…ctor(System.String[])
at LRM.Program.Main(System.String[])

And:
Faulting application name: LRM.exe, version: 4.3.1.0, time stamp: 0x6152cef1
Faulting module name: KERNELBASE.dll, version: 10.0.22000.132, time stamp: 0xf5a91e93
Exception code: 0xe0434352
Fault offset: 0x0013e7b2
Faulting process id: 0x6ec4
Faulting application start time: 0x01d7c07bb0594ea1
Faulting application path: C:\Program Files (x86)\Landing Rate Monitor\LRM.exe
Faulting module path: C:\WINDOWS\System32\KERNELBASE.dll
Report Id: dc2fd8cd-804c-41d0-b9e1-ae2218bb39e8
Faulting package full name:
Faulting package-relative application ID:

Update:
Installed the old version from the link you provided and it works fine in windows 11, so it is just the newer version (4.3.x) that has the issue.

Hi Auxilio, welcome to the forums!

Since posting this update, we’ve discovered that the probable cause is due to a regional setting in Windows.

I’m not familiar with Windows 11 as I am still running Windows 10 myself, but perhaps the process is similar, if not the same.

  1. Click the Start button and search for “region”.
  2. Click Region settings.
  3. On the right side under Related Settings, click “Additional date, time & regional settings”.
  4. Click “Region”.
  5. Click “Additional settings…”
  6. Change the “Decimal symbol” to a period/dot (.).
  7. Click Apply, then OK.
  8. Click OK again to close the Region settings window.

After completing the above steps, try LRM v4.3.1 again. It should work this time.

We are working on a fix for this. In the meantime, these steps should allow you to use the newest client without issue.

Please let us know if it still doesn’t work!

Thanks will try that tomorrow :slightly_smiling_face:

Hello, new version doesn’t even start. Nothing happens. Old version working just fine.
Win10 updated to latest updates.
EDIT: Your tip to replace decimal symbol worked for me!! :+1:

Hey all,

A new version has been released which should resolve this issue (caused by regional settings), see details and a download link here:

LRM Client 4.3.2 ready for testing (fixes for client not starting) - News And Announcements - FsHub Community

If you could report your experience that would be great :+1:

Thanks,
Bobby

LRM keeps saying disconnected anyway to fix that

Hi @MrFujiFudge, welcome to the forums!

Depending on which simulator you’re using, you will need FSUIPC (for FSX, FSX:SE, Prepar3d, or MSFS) or XPUIPC (for X-Plane). Download and install the appropriate version for your simulator and then try again.

Also, if you are running your simulator as Administrator, try running LRM as Administrator as well.

I have installed 4.3.2 and so far it is working, thanks for the speedy fix :slight_smile:

1 Like

Thanks for letting us know Auxillo :slight_smile: