Installing XPUIPC for X-Plane and the LRM Client

This short tutorial will cover how to install and configure the XPUIPC plugin of which will enable the LRM Client to connect to and work with X-Plane.

If you haven’t already, the first step is to install X-Plane on your computer.

Once you have X-Plane installed (we officially support X-Plane 10 and 11) you must then download the XPUIPC plugin (which is free of charge) from this URL: XPUIPC Download Page

It is important to note that for XPUIPC to work correctly you must give your computer a static IP address - you can do this either by assigning it a DCHP lease on your router or by using the Windows Control Panel. - If you don’t know how to set a static IP address I would recommend you watch this YouTube video.

After you have set the static IP address in Windows, make a note of it (as we will need it shortly), the static IP address will be similar to 192.168.0.* or 192.168.1.* but depending on your network configuration could be any mix of numbers separated by dots - the video link above describes how to set this correctly, however :slight_smile:

Once you have downloaded the ZIP file from the above link, double click it to open the contents, it should look as follows:

Right-click and choose Copy on the directory named XPUIPC as shown here:

Let’s now navigate to the folder where X-Plane is installed on our PC (for me, this is D:\X-Plane 11), the folder should look appear as follows:

Now open up the Resources directory as shown in the above screenshot, once you are in the Resources directory, locate and double click on the plugins directory (to open the plugins directory) and then, right-click and choose Paste from the menu:

A new folder (named XPUIPC) should now appear like so:

Open up the new XPUIPC directory and then right-click on the file named XPUIPC.INI and from the context menu click Edit:

Notepad (or whatever program you have set to your default text editor) should now open and display the contents of the file, the ONLY setting we have to change in this file is to set our computer’s static IP address, the default IP address that is set in the file (10.0.0.2) should be changed now to match your static IP address as shown here:

Now we simply need to update the IP address with our own static IP address that you should have set at the start of this tutorial - for the sake of this tutorial, my static IP address is 192.168.1.201 (but you should replace this with whatever your IP address is)

So now, let’s change the IP address line in the file to match yours like so:

Now simply save the file!

If you already have X-Plane open at this point, ensure that you close it and re-open it now…

Start a new flight in X-Plane and once you’re loaded into the simulator, you’re inside of the aircraft and are sitting on the runway (or at the gate etc)… open the LRM client - if all went to plan and you have successfully configured the XPUIPC plugin, the LRM client window should indicate that it is connected to the simulator successfully in the bottom left corner as per my screenshot below:

Please note that you DO NOT have to open the LRM client only once your aircraft is on the runway or at the gate - LRM will automatically connect to it even if LRM client was opened BEFORE X-Plane or if you have enabled the “Blackbox mode” in the LRM client - the above instructions are just for this tutorial purposes!

Please also note that if you start your flight simulator using the “Run As Administrator” feature in Windows then you MUST also use the “Run As Administrator” feature when starting the LRM client too - If you do not do this, the LRM client will not connect and you will see a red “Disconnected” message instead!

Good job! - That’s all there is to it and you can now record your flights using and the LRM client (and FsHub if you choose to enable that option in the LRM Client).

If you have any issue using LRM client (and/or FsHub) with X-Plane 10 or 11 please create a new topic in our Support > LRM Client category and a member of the team or community will help you get it sorted but please ensure that you tell us in your new post/topic the following information so we can diagnose your issue faster:

  • The version of X-Plane you are using
  • The version of the XPUIPC plugin you have downloaded/installed
  • The version of LRM client that you are using
  • If the “Connected” message is shown at the bottom left of the LRM client window when your aircraft is loaded in the simulator or not.

Well, that’s it, hopefully, this helped you guys out :slight_smile:

Video was way to fast for me to grasp. However, the server address for my computer is: 10.0.0.1 as shown in the video. I verified it through windows. Still no connect.

Just wondering then, on the off chance… have you (for whatever reason) disabled network access to X-Plane in the Windows Firewall? - I believe that XPUIPC must have access to XP11 over the network and as such, you must have the firewall open for XP11.

Also - I assume you’re using XP11? (as this is what I tested this process on and unfortunately I don’t own a copy of XP10)

Also, given that you already attempted to install it the other day, it might be worth deleting the XPUIPC directory from you *\X-Plane 11\Resources\plugin directory and attempting my instructions from the start (as these definitely work given that I tested it thoroughly this evening) - just incase you edited other things too when you orginally attempted it.

I’ll keep my fingers crossed for you, please report back on how it goes!

X-plane is allowed. Note, other programs work with XPUIPC in X-Plane. It is shown in the manager.

My installation of XPUIPC is fine. LRM just does not seem to recognize my server. At times it says so.

XP11 is what I am using.
A search of the internet says I have to purchase a static IP address from my supplier?

Hi wvernonc.

No, you should not need to purchase a static IP address from your ISP. I’ve run into similar problems with another piece of software before. The way it was solved there was that if you’re running X-Plane as Administrator, you needed to run the client as Administrator as well.

I would recommend trying to run LRM as Administrator if your X-Plane is set to run as Administrator. Likewise, if your X-Plane is not set to run as Administrator, make sure you also are not running LRM as Administrator.

Let us know how that goes. Hopefully it helps! If not we can investigate further.

That is most strange @wvernonc I’ve not experienced those issues before and equally, I’ve not received any emails or support requests from other users with the same issues as what you’re experiencing :frowning:

Firstly - I would love to get to the bottom of this issue so please bear with us as we will work with you to get this working.

Secondly - I would recommend you see @Clorix response and suggestion above and try that (if you are, for whatever reason running X-Plane “As Administrator”

If @Clorix suggestion fails to work too please could you let me know the names of the other “plugins” that you say are working fine with your X-Plane 11/XPUIPC installation as I will look into what could be different between LRM client and the other plugins that work fine on your computer.

Please also upload and attach any error messages - you mentioned that LRM client complains about not being able to connect to XPUIPC sometimes? - This will help us debug further.

Sorry that you’re experiencing these issues but as I said above, we will get to the bottom of this and it is strange that this is the first time that these issues appear to have cropped up.

Ps. You definately DO NOT need to purchase a static IP address from your ISP - ISP static IP addresses are “pbulic” IP addresses on the internet and are different to a private LAN IP address :slight_smile:

Hi @wvernonc,

Please do me a little favor and look up your ip settings. I was wondering, because the address 10.0.0.1 for a client in your network is very (very) unikely. You a probably mis-matching that with your gateway.
There is a very easy way to verify, that you got indeed the right address.

  • Hit your windows key and type “cmd” without quotes.
  • Hit enter, a small, black, window is going to open.
  • In there you can simply type “ipconfig /all” without quotes.
  • Please send us this whole information. You do not need to worry, no private information will be shared that way. I attached mine to this post, so you are able to see what we are looking for.

Lastly, I have two question. Are you connected via wifi or ethernet? By any chance do you know the brand of your router?

If you are not familiar with running commands on your machine, no worries, I got your back :grinning_face_with_smiling_eyes:. There is a script attached as well. It will simply do the job for you. The script will tell you what to do, after it is done. You just need to upload the “uploadme.txt” to the forums. Won’t take more than 2 seconds, promised :slight_smile:.

Please find my example output file here: click
And the mentioned script here: click

Enjoy your sunday!
thunfischbaum

To all concerned. Problem may be solved. I run X-Plane as Administrator. When I switched LRM to run as Administrator, it connected. As I was about to close my computer for the night, X-Plane crashed. I will test more today. PROGRESS!

1 Like

Oh this is excellent news! - Fingers crossed for when you next attempt it then :smiley:

Please keep us updated!

Enjoy your sleep @wvernonc

P.S If the “Run as administrator” works for you please let me know and I will update the tutorial/documentation so that others don’t fall short and have this issue in future too :slight_smile:

1 hour and 35 minutes flight with X-Plane. Perfect! No issues at all with LRM.

2 Likes

That’s great to know and thanks for the update! - I will update the original post with a warning to other users of whom may “Run As Administrator” :+1: